World Sea Fishing Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
3,698 Posts
Discussion Starter #1
Has anyone got a workshop manual for a 12hp Penta 120? I bought this engine which is in brand new condition - used for a two week holiday , put away and forgotten. Starts first time and runs well but there is no water coming out of the tell tail. Ive tried cleaning the hole - pumping air through, put the hose pipe on it . Still nothing. I suspect it needs a new impeller How do I get at it to check? Tried dropping leg off but its connected to something inside!
Any recommendations for a good book on maintenance - the RYA outboard book is too basic?
 

·
Registered
Joined
·
5,557 Posts
You need a new impeller but before you bother trying to get the leg off try getting the impeller. These engines stopped being made in the 60's with Volvo going over to inboards exclusively. Once you source an impeller (if you can) I can tell you ho to get the leg off.
 

·
Registered
Joined
·
3,698 Posts
Discussion Starter #6
The only rubber object on the leg is the fitting for a bilge pump type tube and filter. Its covered by a rubber cap on the leg just below the power unit. Is that what you mean?
 

·
Registered
Joined
·
5,557 Posts
I don't think it sounds likethe type with the plug, there are some with a flat gromet type plug on the side of the leg about half way down.

Ok, take the bolts out around the top of the gearbox where it joins to the leg. If you have a trim tab just over the prop there may be a bolt hidden under there so remove the trim tab. When all the fixings are removed a bit of gentle persuasion may be needed to drop the gearbox out of the leg. Use a hide faced hammer to gently persuade it. If that fails shout, there are other ways to separate it.
 

·
Registered
Joined
·
3,698 Posts
Discussion Starter #8
Thanks very much. I cant get to it till the weekend now. Preparing dinghy and two engines for first use thursday after 18 month lay up. Cant even find boat rod and reel!!! Will be in touch by private mail
 

·
Registered
Joined
·
3,698 Posts
Discussion Starter #9
I know what you mean about the flat grommet. No there's not one on this one.
Okay 4 bolts out and the gearbox separated without problem by one inch only. Very free. The gear shift went into forward. If put bacck to neutral it raises the gearbox back into place. It feels as if the is something holding it all higher up the leg.
 

·
Registered
Joined
·
724 Posts
Try putting the gear into reverse, then disconnect the gear shift rod, counting the turns so it goes back in the same position
 
1 - 14 of 14 Posts
Top