World Sea Fishing Forums banner
21 - 29 of 29 Posts

· Registered
Joined
·
1 Posts
Was hoping someone could help or advise.Recently bought green 6500 mag elite off ebay.Have noticed spool is off centre.Took the spool out to clean bearings but thats as far as i dare go for now.There is no play on the side with bullet spacer and adjusting knobs on side plates has no effect.Previous owner assures me all parts are original but he did send it to abu for repair a few years ago.Could it be something is missing or not installed correctly.It has me and mates stuck.This is my first post.Cheers.
 

· Registered
Joined
·
690 Posts
Hi there bridgo, sorry no one has replied to your 1st post. and welcome to the forum.the only advice i can give you is too take both side plates off and check if any thing is tight or bent like the spindle also check the bullet spacer is fully home and around the right way, on mine it will only fit one way so i assume it is the same on yours,you only need a very slight sideways play on the spool when the mag and the cap by the star drag are loosened off slightly then check too see if the spool spins freely. if you still have no joy post a new post and i am sure somebody more knowledgeably will help.
 

· Registered
Joined
·
105 Posts
Spent 1/2 an hour last week trying to put the mag side back together. Googled for instructions, plenty there but no one seemed to show what I needed. Muddled my way through and it works fine now. Today, I opened this sticky :doh:.

Thanks for posting-this will be my 'go to' for anything ABU from now on.

Cheers

Chris
 
21 - 29 of 29 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top