World Sea Fishing Forums banner
1 - 3 of 3 Posts

·
WSF Hardcore Angler
Joined
·
4,040 Posts
Discussion Starter · #1 ·
having got me new 525m2 a couple of months back and using it from the box a few times its been running fine... i used it off the rocks at the weekend and it got a soaking so thought id take the spool out and give the bearings etc a clean, used lighter fluid to get the blue grease off then added a few drops of yellow rocket fuel but after putting it back together it now runs a lot slower than it did before! Does anyone know whats up please? my experience with reels is limited to giving the bearings a clean out and replacing handles etc i have never got involved in stripping them right down and i dont realy want to but need to sort this asap

do i just need to take the spool out and give it more of a clean? Any help would be great please, i realy like the reel and like i said its been fine since i got it, no problems with line getting trapped or blowing up, not as fast as my abus but i was expecting
 

·
Registered
Joined
·
2,086 Posts
I've never had a penn but if I was you I'd just start again soak the bearings for about 30 mins in lighter fuel then pop them on a piece of kitchen roll & leave for another 30 mins, then just a couple of drops of whatever oil you use & it should be fine, maybe the oil you used was thicker than the stock one which would explain a slight slow down or there might be a bit of stubborn grease got in the bearing somehow, Rob.......
 

·
Registered
Joined
·
2,326 Posts
A FEW drops might be too much. 2 or 3 is plenty.
When you oil them, leave them lying flat for a while before re-installing them.
Also, often takes a few casts, or even a whole session or 2 for the bearings to come up to speed.
 
1 - 3 of 3 Posts
Top