World Sea Fishing Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
386 Posts
Discussion Starter · #1 ·
Whilst fishing last few days started getting a problem with anti reverse lever - when cast and reel line tight it dosnt stop the spool so the lines keeps running, sometimes it does click and stop so obviously not completly gone.

Anyone know how to fix anti reverse problems, is it best to take to a repair centre or easy enough to do yourself?

I had decided the surfmasters bad reputation was unfair as had some good use out of it and found it nice for casting, been reliable up untill now although it has been abused more or less every day for the last 4 months
 

·
Registered
Joined
·
1,277 Posts
best bet would be to take the side covers off the reel (a few crosshead/pozi screws and take off the handle too) and see if anything obvious looks out of place, might be worth finding a schematic diagram of the reel too so you have a better idea how it should look. might find a spring has slipped out of place or something silly. hope this helps. Lukey.
 

·
Read Only
Joined
·
14,609 Posts
can happen with some reels if the Antireverse bearings got too much grease in it, flush it if its that and it will fix it.
4 months ???
could look up qm reels in plymo hed fix it get any parts etc.
 

·
Registered
Joined
·
8,264 Posts
the reel has the old fashioned pawl system (it has two 4 and 4a on the diagram) so doesn't have an IAR bearing. if the antireverse works sometimes then it suggests that its not switching properly as a serious problem at the pawl will usually mean they don't work at all ... not definitive though as they can be very tweaky at times. You'll probably need to get the roller head off (part 27) to see how the pawl mechanism behaves when you switch it ... and take the sidecover off so you can see the connection to the switch. If you find a spring loose somewhere then thats an obvious clue. Interestingly the Shakespear Salt reels have a similar problem of doing this.
 
1 - 5 of 5 Posts
Top